We’re making improvements to the app

Incident Report for Atom Bank

Resolved

This incident has been resolved.
Posted Sep 01, 2025 - 05:59 BST

Investigating

You won’t be able to log in from 04:00 on 01/09/2025 for approximately 2 hours.

Sorry for any inconvenience that this may cause.
Posted Aug 30, 2025 - 13:05 BST