We’re making improvements to the app

Incident Report for Atom Bank

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 04:32 GMT

Investigating

You won’t be able to log in from 02:00 on 25/02/2026 for approximately 4 hours.
Sorry for any inconvenience that this may cause.
Posted Feb 24, 2026 - 09:28 GMT