Our app is currently unavailable
Incident Report for Atom Bank
Resolved
This incident has been resolved.
Posted Nov 13, 2024 - 06:55 GMT
Investigating
Sorry, we’ve got a few technical issues so you can’t use the app right now.
We’re working to fix this — please try again later.
If you need help with your account, please call us on 0333 399 0050. We can answer general questions via email at customersupport@atombank.co.uk.
Posted Nov 13, 2024 - 06:05 GMT