Mortgage system update

Incident Report for Atom Bank

Resolved

This incident has been resolved.
Posted Nov 22, 2025 - 08:38 GMT

Investigating

You won’t be able to view your mortgage details from 07:00 on 22/11/2025 for approximately 5 hours.

Sorry for any inconvenience that this may cause.
Posted Nov 21, 2025 - 12:40 GMT