We’re making improvements to the app

Incident Report for Atom Bank

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 12:32 BST

Investigating

Our team will be hard at work making improvements to the app between:

Start time: 12:30 on 14/04/2025
End time: 13:00 on 14/04/2025

You can still use the app, but it may be slower than usual. Or, you could try again later.

Sorry for any inconvenience that this may cause.
Posted Apr 14, 2025 - 12:04 BST