You may experience issues funding a new account
Incident Report for Atom Bank
Resolved
This incident has been resolved.
Posted Nov 19, 2024 - 14:36 GMT
Investigating
Sorry, but we’re having some technical issues funding new accounts right now, so you may experience an error with your bank when trying to do this.

Don’t worry though, we’re working to fix this and will be working as usual soon.
Posted Nov 19, 2024 - 14:02 GMT