Mortgage System Update
Incident Report for Atom Bank
Resolved
This incident has been resolved.
Posted Jan 18, 2025 - 14:01 GMT
Investigating
Our team will be hard at work making improvements this weekend. You won’t be able to view mortgage details during this time.

Start time: 07:00 on 18/01/2025
End time: 14:00 on 18/01/2025

Sorry for any inconvenience that this may cause.
Posted Jan 17, 2025 - 10:50 GMT