We’re making improvements to the app

Incident Report for Atom Bank

Resolved

This incident has been resolved.
Posted May 06, 2026 - 07:22 BST

Investigating

At 05:00 on 06/05/2026 for approximately 2 hours we’ll be making some important updates to our app.

During this window any new notifications and funding newly opened accounts may be impacted.

Sorry for any inconvenience caused.
Posted May 05, 2026 - 16:56 BST