We’re making improvements to the app

Incident Report for Atom Bank

Resolved

This incident has been resolved.
Posted May 19, 2026 - 06:40 BST

Investigating

You won’t be able to log in from 05:00 on 19/05/2026 for approximately 2 hours.
Sorry for any inconvenience that this may cause.
Posted May 18, 2026 - 11:53 BST