Spot a scam before it spots you

Incident Report for Atom Bank

Update

Currently we are seeing an industry scam where fraudsters are advertising on social media or sending WhatsApp messages with fixed rate saver deals paying attractive rates. Always be vigilant when opening new accounts and making payments. If you are in any doubt please call us. Our contact hours are 8am-8pm.
Posted Jul 07, 2026 - 21:52 BST

Investigating

Currently we are seeing an industry scam where fraudsters are advertising on social media or sending WhatsApp messages with fixed rate saver deals paying extremely attractive rates. Please be extremely vigilant when making payments to new investments. If in doubt, call us! Our contact hours are 8am-8pm.
Posted Jul 07, 2026 - 21:04 BST