We’re making improvements to the app

Incident Report for Atom Bank

Resolved

This incident has been resolved.
Posted Jul 09, 2025 - 06:13 BST

Investigating

From 06:00 on 09/07/2025 for approximately 1 hour, any notifications you usually receive from our app may be delayed.

Sorry for any inconvenience caused.
Posted Jul 08, 2025 - 22:04 BST