We’re making improvements to the app

Incident Report for Atom Bank

Resolved

This incident has been resolved.
Posted Feb 13, 2025 - 03:22 GMT

Investigating

You won’t be able to log in from 02:00 on 13/02/2025 for approximately 3 hours.

Sorry for any inconvenience that this may cause.
Posted Feb 12, 2025 - 12:18 GMT