You may experience issues funding a new account

Incident Report for Atom Bank

Resolved

This incident has been resolved.
Posted Feb 04, 2025 - 10:56 GMT

Investigating

Sorry, we’re having some technical issues funding new accounts right now, so you may experience an error with your bank when trying to do this.

Don’t worry though, we’re working to fix this and will be working as usual soon.
Posted Feb 04, 2025 - 09:52 GMT