We’re making improvements to the app.
Incident Report for Atom Bank
Resolved
This incident has been resolved.
Posted Nov 20, 2024 - 06:40 GMT
Update
Our team will be hard at work making improvements to the app, so you won’t be able to log in from:

Start time: 06:00 on 20/11/2024
End time: 07:00 on 20/11/2024

Sorry for any inconvenience that this may cause
Posted Nov 20, 2024 - 06:20 GMT
Update
We are continuing to investigate this issue.
Posted Nov 20, 2024 - 05:59 GMT
Investigating
Our team will be hard at work making improvements to the app, so you won’t be able to log in from:

Start time: 06:00 on 20/11/2024
End time: 07:00 on 20/11/2024

Sorry for any inconvenience that this may cause
Posted Nov 19, 2024 - 20:59 GMT