Our app is currently unavailable
Incident Report for Atom Bank
Resolved
This incident has been resolved.
Posted Jan 13, 2025 - 14:47 GMT
Update
Sorry, we’ve got a few technical issues so you can’t use the app right now.
We’re working to fix this — please try again later.

If you need help with your account, please call us on 0333 399 0050. We can answer general questions via email at customersupport@atombank.co.uk.
Posted Jan 13, 2025 - 14:31 GMT
Investigating
Sorry, our app isn’t running at full speed right now — we’re working to fix this.
You can still use the app, but it may be slower than usual. Or, you could try again later.
Posted Jan 13, 2025 - 14:00 GMT