Hi again!

Incident Report for Atom Bank

Resolved

This incident has been resolved.
Posted Oct 08, 2025 - 20:56 BST

Investigating

Don't mind us, we're just doing a little service test. Just head on into the app and you can manage your money as usual.
Posted Oct 08, 2025 - 20:54 BST