We’re making improvements to the app

Incident Report for Atom Bank

Resolved

This incident has been resolved.
Posted Nov 26, 2025 - 08:27 GMT

Update

You won’t be able to log in from 07:00 on 26/11/2025 for approximately 1 hour.

Sorry for any inconvenience that this may cause.
Posted Nov 25, 2025 - 15:20 GMT

Update

You won’t be able to log in from 07:00 on 25/11/2025 for approximately 1 hour.

Sorry for any inconvenience that this may cause.
Posted Nov 25, 2025 - 15:03 GMT

Investigating

You won’t be able to log in from 07:00 on 25/11/2025for approximately 1 hour.

Sorry for any inconvenience that this may cause.
Posted Nov 25, 2025 - 15:00 GMT