We’re making improvements to the app

Incident Report for Atom Bank

Resolved

This incident has been resolved.
Posted Nov 27, 2025 - 07:37 GMT

Investigating

You won’t be able to log in from 07:00 on 27/11/2025 for approximately 1 hour.

Sorry for any inconvenience that this may cause.
Posted Nov 26, 2025 - 16:02 GMT