We’re making improvements to the app

Incident Report for Atom Bank

Resolved

This incident has been resolved.
Posted Feb 05, 2025 - 05:28 GMT

Investigating

You won’t be able to log in from 02:00 on 05/02/2025 for approximately 4 hours.

There will also be a delay to any inbound payments being credited to your account.

Sorry for any inconvenience that this may cause.
Posted Feb 04, 2025 - 12:01 GMT